FIRST-CODER VERSION 2.1.5

This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

  • FIRST-CODER VERSION 2.1.5

    English:

    Hello Community,

    today I present you the Version 2.1.5-OPEN-PRE-ALPHA. Its completely developed from scratch and uses a new password hash. This is the reason, why the update isn't available via the interface. Therefore im asking for support. Also, not all features are available yet, but they will become available soon. The following features are missing for now:

    • Themes
    • Splamy Musicbot
    • Serverapplications
    • Serverbanners


    I already implemented the Splamy bot partwise, that's why the bot-instance.php aleady exists, but isn't funktional yet. I know that it is important to you all, therefore it will be implenented right after the serverapplications, which should only take a couple of weeks. I've added the mails section but due to missing time, I hadn't had time yet to test it via the installscript. I still hope it works without any issues, if not, please tell me!

    It's not necessary anymore to use an external database anymore. You can use a sqlite database now. That way, everything can stay on the webspace. I think this is an important step to replace psychokillers interface in the future. Everything else can be read in the changelog, which is to be found here: first-coder.de/index.php?tsw?download

    I wish you a nice weekend.
    L. Gmann - Developer

    German:

    Hallo Community,

    ich präsentiere heute die Version 2.1.5-OPEN-PRE-ALPHA. Sie ist eine komplette Neuentwicklung und verwendet ein neues Passwort Hash. Deswegen ist ein Update via Interface nicht möglich. Ich bitte daher um Unterstützung. Zudem sind nicht alle Funktionen bereit, welche aber im späteren Verlauf hinzugefügt werden. Momentan fehlen folgende Funktionen:

    • Themes
    • Splamy Musicbot
    • Serverantrag
    • Serverbanner


    Der Splamy Musicbot ist zum Teil schon implementiert, weswegen im config Ordner die bot-instance.php schon existiert. Ich weiß, dass der Splamy Bot euch wichtig ist, daher wird dieser direkt nach dem Serverantrag implementiert. Dies sollte nur wenige Wochen dauern. Ich habe am Ende noch die Mails section hinzugefügt und konnte sie via Installscript nicht selber testen, da die Zeit gefehlt hat. Ich hoffe, dass die Installation trotzdem fehlerfrei funktioniert. Falls nicht, so schreibt mir bitte!

    Zudem ist es nun nicht mehr notwendig eine externe Datenbank zu besitzen. Ihr könnt nun das Interface via sqlite Datenbank installieren. Somit bleibt alles auf dem Webspace. Ich denke dies ist ein wichtiger Schritt um in Zukunft psychokillers Interface abzulösen. Alles weitere kann auch hier im Changelog nachgelesen werden: first-coder.de/index.php?tsw?download

    In diesem Sinne noch ein schönes Wochenende.
    L. Gmann - Developer

    *UPDATE 26.05.19 - 19:37: Version had some copyright protection issues. They are fixed now. Download the new version over my webpage first-coder.de
    *UPDATE 27.05.19 - 14:29: Version 2.1.5 was complete broken. Sry for that :/ I´ve published now Version 2.2.6. This Version should work like 2.1.5 should. I can´t make a update cause the updater in 2.1.5 is also broken :(

    The post was edited 1 time, last by Solace: Translation :D ().